본문 바로가기
알고리즘/문제 풀이(출처 : 백준)

[JAVA] 테트로미노_14500

by 이민우 2022. 10. 10.
728x90
반응형

https://www.acmicpc.net/problem/14500

 

14500번: 테트로미노

폴리오미노란 크기가 1×1인 정사각형을 여러 개 이어서 붙인 도형이며, 다음과 같은 조건을 만족해야 한다. 정사각형은 서로 겹치면 안 된다. 도형은 모두 연결되어 있어야 한다. 정사각형의 변

www.acmicpc.net

 

 

테트로미노 성공

 
시간 제한메모리 제한제출정답맞힌 사람정답 비율
2 초 512 MB 64188 23956 15580 35.540%

문제

폴리오미노란 크기가 1×1인 정사각형을 여러 개 이어서 붙인 도형이며, 다음과 같은 조건을 만족해야 한다.

  • 정사각형은 서로 겹치면 안 된다.
  • 도형은 모두 연결되어 있어야 한다.
  • 정사각형의 변끼리 연결되어 있어야 한다. 즉, 꼭짓점과 꼭짓점만 맞닿아 있으면 안 된다.

정사각형 4개를 이어 붙인 폴리오미노는 테트로미노라고 하며, 다음과 같은 5가지가 있다.

아름이는 크기가 N×M인 종이 위에 테트로미노 하나를 놓으려고 한다. 종이는 1×1 크기의 칸으로 나누어져 있으며, 각각의 칸에는 정수가 하나 쓰여 있다.

테트로미노 하나를 적절히 놓아서 테트로미노가 놓인 칸에 쓰여 있는 수들의 합을 최대로 하는 프로그램을 작성하시오.

테트로미노는 반드시 한 정사각형이 정확히 하나의 칸을 포함하도록 놓아야 하며, 회전이나 대칭을 시켜도 된다.

입력

첫째 줄에 종이의 세로 크기 N과 가로 크기 M이 주어진다. (4 ≤ N, M ≤ 500)

둘째 줄부터 N개의 줄에 종이에 쓰여 있는 수가 주어진다. i번째 줄의 j번째 수는 위에서부터 i번째 칸, 왼쪽에서부터 j번째 칸에 쓰여 있는 수이다. 입력으로 주어지는 수는 1,000을 넘지 않는 자연수이다.

출력

첫째 줄에 테트로미노가 놓인 칸에 쓰인 수들의 합의 최댓값을 출력한다.

예제 입력 1 복사

5 5
1 2 3 4 5
5 4 3 2 1
2 3 4 5 6
6 5 4 3 2
1 2 1 2 1

예제 출력 1 복사

19

예제 입력 2 복사

4 5
1 2 3 4 5
1 2 3 4 5
1 2 3 4 5
1 2 3 4 5

예제 출력 2 복사

20

예제 입력 3 복사

4 10
1 2 1 2 1 2 1 2 1 2
2 1 2 1 2 1 2 1 2 1
1 2 1 2 1 2 1 2 1 2
2 1 2 1 2 1 2 1 2 1

예제 출력 3 복사

7

출처

알고리즘 분류

 

 

package baekjoon;

import java.util.Scanner;

public class Main
{
    private static Scanner s = new Scanner(System.in);
    private static int answer = Integer.MIN_VALUE;
    
	public static void main(String[] args) {
		
		int N=s.nextInt(); //가로
		int M=s.nextInt(); //세로
		
		//종이 초기화
		int[][] paper = new int[N][M];
		
		for(int i=0; i<N; i++) {
			for(int j=0; j<M; j++) {
				paper[i][j] = s.nextInt();
			}
		}
		
		//그냥 무식하게 풀어도 될듯.
		//각 칸마다 나올 수 있는 네 개의 도형을 대입하여 가장 큰 값 찾기
		for(int i=0; i<N; i++) {
			for(int j=0; j<M; j++) {
				int tmp = Integer.MIN_VALUE;
				// ㅣ
				tmp = line(i, j, paper);
				if(tmp > answer) answer = tmp;
				// ㅁ
				tmp = square(i, j, paper);
				if(tmp > answer) answer = tmp;
				// L
				tmp = l(i, j, paper);
				if(tmp > answer) answer = tmp;
				// 번개
				tmp = thunder(i, j, paper);
				if(tmp > answer) answer = tmp;
				// ㅗ
				tmp = bolok(i, j, paper);
				if(tmp > answer) answer = tmp;
			}
		}
		
		System.out.println(answer);
		
	}
	
	// ㅣ 1*4
	private static int line(int i, int j, int[][] paper) {
		int width = Integer.MIN_VALUE; //가로
		int height = Integer.MIN_VALUE; //세로
		//가로 구하기 (범위 넘어서면 에러이므로 MIN_VALUE
		try {
			width = paper[i][j] + paper[i][j+1] + paper[i][j+2] + paper[i][j+3];
			
		}
		catch(Exception e) {
			width = Integer.MIN_VALUE;
		}
		//세로 구하기
		try {
			height = paper[i][j] + paper[i+1][j] + paper[i+2][j] + paper[i+3][j];
		}
		catch(Exception e) {
			height = Integer.MIN_VALUE;
		}
		
		return Math.max(width, height);
	}
	// ㅁ 2*2
	private static int square(int i, int j, int[][] paper) {
		int square = Integer.MIN_VALUE;
		
		try {
			square = paper[i][j] + paper[i][j+1] + paper[i+1][j] + paper[i+1][j+1];
		}
		catch (Exception e) {
			square = Integer.MIN_VALUE;
		}
		
		return square;
	}
	// L
	private static int l(int i, int j, int[][] paper) {
		int l = Integer.MIN_VALUE;
		int tmp = 0;
		
		// L
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+2][j] + paper[i+2][j+1];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ┛
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+2][j] + paper[i+2][j-1];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ─┘
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i][j+2] + paper[i-1][j+2];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// └─
		try {
			tmp = paper[i][j] + paper[i][j-1] + paper[i][j-2] + paper[i-1][j-2];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ─┐
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i][j+2] + paper[i+1][j+2];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ┌─
		try {
			tmp = paper[i][j] + paper[i][j-1] + paper[i][j-2] + paper[i+1][j-2];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ┏
		try {
			tmp = paper[i][j] + paper[i-1][j] + paper[i-2][j] + paper[i-2][j+1];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		// ┓
		try {
			tmp = paper[i][j] + paper[i-1][j] + paper[i-2][j] + paper[i-2][j-1];
			if(tmp > l) l = tmp;
		}
		catch (Exception e) {
		}
		
		return l;
	}
	// 번개
	private static int thunder(int i, int j, int[][] paper) {
		int tmp = 0;
		int t = Integer.MIN_VALUE;
		
		// └┐
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+1][j+1] + paper[i+2][j+1];
			if(tmp > t) t = tmp;
		}
		catch(Exception e) {
		}
		
		// ┌┘
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+1][j-1] + paper[i+2][j-1];
			if(tmp > t) t = tmp;
		}
		catch(Exception e) {
		}
		
		//  ┌
		// ┘
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i-1][j+1] + paper[i-1][j+2];
			if(tmp > t) t = tmp;
		}
		catch(Exception e) {
		}
		
		// ┐
		//  └
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i+1][j+1] + paper[i+1][j+2];
			if(tmp > t) t = tmp;
		}
		catch(Exception e) {
		}
				
		return t;
	}
	// ㅗ
	private static int bolok(int i, int j, int[][] paper) {
		int b = Integer.MIN_VALUE;
		int tmp = 0;
		
		// ㅗ
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i-1][j+1] + paper[i][j+2];
			if(tmp > b) b = tmp;
		}
		catch(Exception e) {
			
		}
		// ㅜ
		try {
			tmp = paper[i][j] + paper[i][j+1] + paper[i+1][j+1] + paper[i][j+2];
			if(tmp > b) b = tmp;
		}
		catch(Exception e) {
			
		}
		// ㅏ
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+1][j+1] + paper[i+2][j];
			if(tmp > b) b = tmp;
		}
		catch(Exception e) {
			
		}
		// ㅓ
		try {
			tmp = paper[i][j] + paper[i+1][j] + paper[i+1][j-1] + paper[i+2][j];
			if(tmp > b) b = tmp;
		}
		catch(Exception e) {
			
		}
		
		return b;
	}
	
}
728x90
반응형

'알고리즘 > 문제 풀이(출처 : 백준)' 카테고리의 다른 글

[JAVA] 2048(Easy)_12100  (0) 2022.10.14
[JAVA] 경사로_14890  (0) 2022.10.11
[JAVA] 로봇 청소기_14503  (0) 2022.10.10
[Java] 연산자 끼워넣기_14888  (0) 2022.09.10
[JAVA] DFS와 BFS_1260  (0) 2022.05.27